Author Topic: Can't get vulkan working on opensuse leap 15.4  (Read 1780 times)

power9mm

  • Jr. Member
  • **
  • Posts: 95
  • Karma: +8/-3
    • View Profile
Can't get vulkan working on opensuse leap 15.4
« on: February 01, 2023, 01:45:00 pm »
EDIT: nevermind, there aren't vulkan drivers for openSUSE ppc64le



The library is installed, it worked perfectly under x86. however any applications with a vulkan renderer just crash, basically saying there isn't vulkan available.

===========
VULKAN INFO
===========

Vulkan API Version: 1.0.65

ERROR: [Loader Message] Code 0 : libVkICD_mock_icd.so: cannot open shared object file: No such file or directory
Cannot create Vulkan instance.
/home/abuild/rpmbuild/BUILD/Vulkan-LoaderAndValidationLayers-1.0.65.0/demos/vulkaninfo.c:808: failed with VK_ERROR_INCOMPATIBLE_DRIVER
« Last Edit: February 01, 2023, 04:39:04 pm by power9mm »

power9mm

  • Jr. Member
  • **
  • Posts: 95
  • Karma: +8/-3
    • View Profile
Re: Can't get vulkan working on opensuse leap 15.4
« Reply #1 on: February 01, 2023, 01:52:13 pm »
----- Client Shutdown (Server fatal crashed: VKimp_Init() - could not load Vulkan subsystem) -----
RE_Shutdown( 3 )
-----------------------
Sys_Error: VKimp_Init() - could not load Vulkan subsystem

tle

  • Sr. Member
  • ****
  • Posts: 434
  • Karma: +47/-0
    • View Profile
    • Trung's Personal Website
Re: Can't get vulkan working on opensuse leap 15.4
« Reply #2 on: February 27, 2023, 04:52:06 am »
I wish I could help but I have not used this distro before. Perhaps this could be an oversight from the dev team. I highly recommend you ask the OpenSuSE community or lodge a ticket with them instead.
Faithful Linux enthusiast

My Raptor Blackbird

power9mm

  • Jr. Member
  • **
  • Posts: 95
  • Karma: +8/-3
    • View Profile
Re: Can't get vulkan working on opensuse leap 15.4
« Reply #3 on: February 27, 2023, 01:00:02 pm »
I don't know how to contact them and suse community isn't super helpful anytime ive ran into issues even on x86. Some even chastising me for my choice in hardware lol

DKnoto

  • Jr. Member
  • **
  • Posts: 79
  • Karma: +13/-0
    • View Profile
Re: Can't get vulkan working on opensuse leap 15.4
« Reply #4 on: March 13, 2023, 05:33:55 am »
…Some even chastising me for my choice in hardware lol
It seems that people for the sake of convenience are able to sacrifice everything ;)
Desktop: Talos II T2P9S01 REV 1.01 | IBM Power 9/18c DD2.3, 02CY646 | AMD Radeon Pro WX7100 | 64GB RAM | SSD 1TB

MauryG5

  • Hero Member
  • *****
  • Posts: 737
  • Karma: +22/-1
    • View Profile
Re: Can't get vulkan working on opensuse leap 15.4
« Reply #5 on: March 29, 2023, 01:52:55 pm »
Ah so they criticized you maybe because you told them that you use Linux on Power am I right? I can imagine the usual narrow-mindedness of these people who never see beyond their nose... What do you have to do with hardware that few have, with something that doesn't exist, with something that has no optimization, no software, etc. etc... The usual ignorant mass in a nutshell!