Author Topic: Blackbird Radeon RX580  (Read 2055 times)

mcarden

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Blackbird Radeon RX580
« on: November 07, 2021, 10:16:19 pm »
A couple of years ago I assembled a Blackbird into a case with a Radeon RX580 GPU, installed a version of Fedora Linux and I don't recall having to do anything special to make it work.

This week I dropped the Radeon back into the Blackbird which now runs Fedora 35 Workstation, and it doesn't produce video.

uname -r
5.14.16-301.fc35.ppc64le


The card is seen along with the aspeed one:

lspci | grep VGA
0000:01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] (rev e7)
0005:02:00.0 VGA compatible controller: ASPEED Technology, Inc. ASPEED Graphics Family (rev 41)


And the kernel is loading modules for it:

lsmod | grep -i amdgpu
amdgpu               8257536  1
drm_ttm_helper        262144  3 drm_vram_helper,ast,amdgpu
ttm                   327680  3 drm_vram_helper,amdgpu,drm_ttm_helper
mfd_core              327680  1 amdgpu
gpu_sched             327680  1 amdgpu
i2c_algo_bit          262144  2 ast,amdgpu
drm_kms_helper        524288  5 drm_vram_helper,ast,amdgpu
drm                   851968  10 gpu_sched,drm_kms_helper,drm_vram_helper,ast,amdgpu,drm_ttm_helper,ttm
i2c_core              327680  8 drm_kms_helper,i2c_algo_bit,at24,ast,amdgpu,i2c_opal,regmap_i2c,drm


The only clue I have found so far comes from dmesg, which says in part:

[  121.619204] amdgpu 0000:01:00.0: [drm] Cannot find any crtc or sizes
[  133.894384] amdgpu 0000:01:00.0: refused to change power state from D0 to D3hot


I don't recall seeing this in the past (though I may have and have just forgotten) but I wonder if someone could point me in the direction of what I'm missing to get this going?

Thanks,
MC


MauryG5

  • Hero Member
  • *****
  • Posts: 628
  • Karma: +21/-1
    • View Profile
Re: Blackbird Radeon RX580
« Reply #1 on: November 08, 2021, 12:54:21 am »
Hi, unfortunately it is the same problem that I have pointed out since the Linux Kernel moved to version 5.14.X.  From this Kernel version onwards, at the moment, AMD GPUs no longer boot and you need a Kernel up to 5.13.19 to make it work.  They showed me a post where they understood the problem but I don't know how to do that procedure they talk about to avoid this ...

ClassicHasClass

  • Sr. Member
  • ****
  • Posts: 300
  • Karma: +24/-0
  • Talospace Earth Orbit
    • View Profile
    • Floodgap
Re: Blackbird Radeon RX580
« Reply #2 on: November 08, 2021, 12:38:16 pm »
What are your kernel command line options? According to https://bugzilla.kernel.org/show_bug.cgi?id=200695 some people have had trouble with amdgpu.dc=1 (setting it to =0 seemed to fix it), though that problem seems to be somewhat old. There are a lot of comparable WX7100 OpenPOWER systems out there which should be the same generation, so I would expect this to be a more widespread problem (but I haven't upgraded my workstation to 35 yet either, planning to do the BMC-only Blackbird this week).

MauryG5

  • Hero Member
  • *****
  • Posts: 628
  • Karma: +21/-1
    • View Profile
Re: Blackbird Radeon RX580
« Reply #3 on: November 08, 2021, 02:21:15 pm »
Hi Classic, the problem I know for sure occurs with Kernels from version 5.14 onwards, including the new 5.15 which I just tested a few days ago and which still suffers from the same bug.  Can you tell me where to go or how to proceed to verify this part you are talking about?  Thanks

mcarden

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: Blackbird Radeon RX580
« Reply #4 on: November 08, 2021, 02:56:51 pm »
@ClassicHasClass, I had tried adding 'amdgpu.dc=0' to the kernel command line on boot but it didn't help.

--
MC

ClassicHasClass

  • Sr. Member
  • ****
  • Posts: 300
  • Karma: +24/-0
  • Talospace Earth Orbit
    • View Profile
    • Floodgap
Re: Blackbird Radeon RX580
« Reply #5 on: November 08, 2021, 03:22:32 pm »
@mcarden, that's distressing because that card should be "known working." I wonder if @tle has already updated. My F34 T2 has a WX7100 and it works fine, but I haven't updated it to F35. Do you get at least Petitboot on screen? Can you force fbdev for Xorg?

MauryG5, I think you have a different issue because you're trying to use a Navi-based card, as memory serves. These are Polaris and should already be working just fine.

sharkcz

  • Newbie
  • *
  • Posts: 11
  • Karma: +0/-0
    • View Profile
Re: Blackbird Radeon RX580
« Reply #6 on: November 08, 2021, 03:32:10 pm »
For the record, you might hit https://gitlab.freedesktop.org/drm/amd/-/issues/1736 on a Polaris card starting with 5.15

If you know the version that worked and what does not, then you can bisect. In this case the iteration times would be short, mine was 1 iteration in a day for the bug above ... If you want a "minimized" kernel config derived from the Fedora one which reduces the compile times significantly, let me know. If you need help about bisecting, I can provide that too :-)

mcarden

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: Blackbird Radeon RX580
« Reply #7 on: November 08, 2021, 03:59:18 pm »
@ClassicHasClass, no output during petitboot, but the aspeed's HDMI does. The card's backlight LEDs for its logo *do* light during petitboot but then go out on boot. I seem to recall they used to stay on when the card was working.F35 is Wayland without the xorg option that earlier Fedoras had.

@sharkcz, I'm really, really hoping to not have to go down any sort of a kernel compiling rabbit Hole.

--
MC

MauryG5

  • Hero Member
  • *****
  • Posts: 628
  • Karma: +21/-1
    • View Profile
Re: Blackbird Radeon RX580
« Reply #8 on: November 08, 2021, 04:45:50 pm »
Yes Classic I know that I have the Navi, only that I say this because I have noticed that every time there is a problem in the Kernel, concerning the AMD GPUs, this occurs indiscriminately on different types of cards, such as Navi, Nano and others ... I therefore believe that the problem is the same also because coincidentally we have the same problems at the same time ... Maybe you have not read this link sent by the friend MPC, here we are talking about Vega, so another model but problem itself. Here they say they have solved but I did not understand anything about how they did unfortunately. If you can better understand what they did then it's great ... I'll post the link ...

https://gitlab.freedesktop.org/drm/amd/-/issues/1723

mcarden

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: Blackbird Radeon RX580
« Reply #9 on: November 08, 2021, 05:46:00 pm »
Progress, of a sort.

Adding 'amdgpu.aspm=0' to the kernel parameters at boot as mentioned at https://gitlab.freedesktop.org/drm/amd/-/issues/1723  results in the card producing video during boot (the Fedora logo at the bottom of the screen and a spinner) but as soon as boot reaches the login screen, video disappears and is only available via the onboard HDMI.

I got all excited seeing video there for a few moments...

--
MC

ClassicHasClass

  • Sr. Member
  • ****
  • Posts: 300
  • Karma: +24/-0
  • Talospace Earth Orbit
    • View Profile
    • Floodgap
Re: Blackbird Radeon RX580
« Reply #10 on: November 08, 2021, 06:32:29 pm »
If you disable gdm (easiest way would be something like `systemctl set-default multi-user.target` or add `systemd.unit=multi-user.target`), do you at least get a text boot? You could try messing with additional options from there. You should still be able to install xorg in F35 even if it didn't come with it.

ClassicHasClass

  • Sr. Member
  • ****
  • Posts: 300
  • Karma: +24/-0
  • Talospace Earth Orbit
    • View Profile
    • Floodgap
Re: Blackbird Radeon RX580
« Reply #11 on: November 08, 2021, 06:35:56 pm »
Yes Classic I know that I have the Navi, only that I say this because I have noticed that every time there is a problem in the Kernel, concerning the AMD GPUs, this occurs indiscriminately on different types of cards, such as Navi, Nano and others ... I therefore believe that the problem is the same also because coincidentally we have the same problems at the same time ... Maybe you have not read this link sent by the friend MPC, here we are talking about Vega, so another model but problem itself. Here they say they have solved but I did not understand anything about how they did unfortunately. If you can better understand what they did then it's great ... I'll post the link ...

https://gitlab.freedesktop.org/drm/amd/-/issues/1723

It looks like it's the same solution, though I still think the underlying issue is different. You could change this in Petitboot or Grub, but either way you want to add add `amdgpu.aspm=0` to your kernel options.

MauryG5

  • Hero Member
  • *****
  • Posts: 628
  • Karma: +21/-1
    • View Profile
Re: Blackbird Radeon RX580
« Reply #12 on: November 09, 2021, 12:43:31 am »
I mainly use Ubuntu 20.04.3 with Xorg and the problem is the same, so I don't think it affects the graphics server.  They changed some damn parameters on the new Kernels and now we have problems and what's worse they still haven't solved it ...!  Classic sorry for Kernel options you mean when configuring the parameters?  Is there this option that you say must be set to 0?  Let me get it right ...

MPC7500

  • Sr. Member
  • ****
  • Posts: 401
  • Karma: +27/-1
    • View Profile
    • Twitter
Re: Blackbird Radeon RX580
« Reply #13 on: November 09, 2021, 05:31:22 am »
@mcarden: I would try to blacklist the AST GPU.

sharkcz

  • Newbie
  • *
  • Posts: 11
  • Karma: +0/-0
    • View Profile
Re: Blackbird Radeon RX580
« Reply #14 on: November 09, 2021, 08:17:52 am »
@ClassicHasClass, no output during petitboot, but the aspeed's HDMI does. The card's backlight LEDs for its logo *do* light during petitboot but then go out on boot. I seem to recall they used to stay on when the card was working.F35 is Wayland without the xorg option that earlier Fedoras had.

@sharkcz, I'm really, really hoping to not have to go down any sort of a kernel compiling rabbit Hole.

--
MC
It's not that bad, I was worried myself :-) I would suggest to start with the drm-next-5.14 branch from the AMD tree and it should be ~10 iterations.