Author Topic: Configure Xorg for AST2500 max resolution of 1920x1200 on Ubuntu Server 19.10  (Read 442 times)

FlyingBlackbird

  • Jr. Member
  • **
  • Posts: 83
  • Karma: +0/-0
    • View Profile
I have installed Ubuntu Server 19.10 with Gnome and lightdm and use the Xorg config from the wiki to enable full HD resolution (https://wiki.raptorcs.com/wiki/Troubleshooting/GPU#Display_stuck_at_default_low_resolution_with_AST_HDMI_GPU).

According to the brief spec (https://www.aspeedtech.com/products.php?fPath=20&rId=440) the AST2500 also supports 1920x1200@60 Hz but I could not successfully enable this resolution.

How do I have to configure Xorg (or is it an error in the spec?)?

My steps tried so far (using the cvt tool to create a modeline for the Xorg.conf and adding this to the Xorg conf file as described in the above link):

Code: [Select]
# usage: cvt [-v|--verbose] [-r|--reduced] X Y [refresh]
cvt 1920 1200 60
cvt -r 1920 1200 60
cvt 1920 1200 30

I have also added the modeline name to the "modes" line of the display (without success):

Ubuntu is never using this resolution and does also not offer it in the display resolution settings dialog of Gnome.

FlyingBlackbird

  • Jr. Member
  • **
  • Posts: 83
  • Karma: +0/-0
    • View Profile
I have found the correct settings now by modiying the xorg.conf from the Raptor wiki just a little bit.

The reason why it didn't work were the conservative HorizSync and VertRefresh settings. After commenting them it did work (at least in Fedora 31)

Code: [Select]
# AST2500
Section "Device"
    Identifier     "GPU0"
    Driver         "modesetting"
    BusID          "PCI:2@5:0:0"
    VendorName     "ASpeed Corporation"
EndSection

# configure as appropriate for your monitor -- a standard 1080p screen is assumed below
Section "Monitor"
    Identifier     "Monitor0"
#    HorizSync       30.0-70.0
#    VertRefresh     50.0-70.0
    Modeline       "1920x1080" 172.80 1920 2040 2248 2576 1080 1081 1084 1118 -HSync +Vsync
# 1920x1200 59.88 Hz (CVT 2.30MA) hsync: 74.56 kHz; pclk: 193.25 MHz
    Modeline       "1920x1200"  193.25  1920 2056 2256 2592  1200 1203 1209 1245 -hsync +vsync
EndSection

# this is absolutely necessary, it tells xorg which GPU to use for the screen
Section "Screen"
    Identifier     "Screen0"
    Monitor        "Monitor0"
    Device         "GPU0"
    DefaultDepth    24
    SubSection "Display"
        Depth       24
        Modes      "1920x1080" "1920x1200"
    EndSubSection
EndSection

I would be happy if somebody could confirm that these settings are working - I will add them then to the according Raptor wiki page.

MPC7500

  • Full Member
  • ***
  • Posts: 189
  • Karma: +11/-0
    • View Profile
    • Twitter
Sadly, I can't test myself. But on the RCSwiki you could describe how to get the needed modeline using cvt command, modeline calculator or looking into Xorg.0.log for supported resolutions etc..

jirka

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
  • Ordinary Blackbird Owner
    • View Profile
    • Jirka's Notes

# 1920x1200 59.88 Hz (CVT 2.30MA) hsync: 74.56 kHz; pclk: 193.25 MHz
    Modeline       "1920x1200"  193.25  1920 2056 2256 2592  1200 1203 1209 1245 -hsync +vsync

I would be happy if somebody could confirm that these settings are working - I will add them then to the according Raptor wiki page.

It worked until yesterday update (but I think that the Fedora 31 updated just the kernel, not the Xorg?!).

Do you have similar experience?
Probably sent from the sforza (a Blackbird workstation with Fedora) or the moose (a SGI O2).

FlyingBlackbird

  • Jr. Member
  • **
  • Posts: 83
  • Karma: +0/-0
    • View Profile

# 1920x1200 59.88 Hz (CVT 2.30MA) hsync: 74.56 kHz; pclk: 193.25 MHz
    Modeline       "1920x1200"  193.25  1920 2056 2256 2592  1200 1203 1209 1245 -hsync +vsync

I would be happy if somebody could confirm that these settings are working - I will add them then to the according Raptor wiki page.

It worked until yesterday update (but I think that the Fedora 31 updated just the kernel, not the Xorg?!).

Do you have similar experience?

My Blackbird planar is dead since February (RMA is done but the new planar is still at USPS in the USA due to Corona transportation bottlenecks so I cannot say anything.

I hope your planar is not dead too ;-)

MPC7500

  • Full Member
  • ***
  • Posts: 189
  • Karma: +11/-0
    • View Profile
    • Twitter
It worked until yesterday update (but I think that the Fedora 31 updated just the kernel, not the Xorg?!).

Do you have similar experience?

What's the problem in detail? Does 1080 resolution work?

jirka

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
  • Ordinary Blackbird Owner
    • View Profile
    • Jirka's Notes
What's the problem in detail? Does 1080 resolution work?

Blank screen, monitor says "no signal". But 1080 works normally (I'm using it now). I had only the 1920x1200 in my Xorg configuration file soi I had to add the 1080 one to see at least something.
Now I have 1920x1080, 1920x1200, 1280x1024 configured (the 1920x are from Raptor Wiki) and I can go to 1280x1024 and back to 1920x1080 but when I trt the 1920x1200 the I got blank the abovementioned blank screen.
Probably sent from the sforza (a Blackbird workstation with Fedora) or the moose (a SGI O2).

MPC7500

  • Full Member
  • ***
  • Posts: 189
  • Karma: +11/-0
    • View Profile
    • Twitter
You could use the cvt command to look if the 1200 modelines has changed.
Otherwise, the Xorg logfile would be useful.
« Last Edit: April 27, 2020, 01:13:48 pm by MPC7500 »

jirka

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
  • Ordinary Blackbird Owner
    • View Profile
    • Jirka's Notes
I'm sorry for late reply.

My X11 boot to 1920x1080 now. Then I have tried to changer resolution to 1280x1024 (it obviously worked) and then to 1920x1200 (blank screen).

The Xorg log file is (attached).
Probably sent from the sforza (a Blackbird workstation with Fedora) or the moose (a SGI O2).

MPC7500

  • Full Member
  • ***
  • Posts: 189
  • Karma: +11/-0
    • View Profile
    • Twitter
What modelines gives you the cvt command?

jirka

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
  • Ordinary Blackbird Owner
    • View Profile
    • Jirka's Notes
What modelines gives you the cvt command?

# 1920x1200 59.88 Hz (CVT 2.30MA) hsync: 74.56 kHz; pclk: 193.25 MHz
Modeline "1920x1200_60.00"  193.25  1920 2056 2256 2592  1200 1203 1209 1245 -hsync +vsync

# 1920x1080 59.96 Hz (CVT 2.07M9) hsync: 67.16 kHz; pclk: 173.00 MHz
Modeline "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync

# 1280x1024 59.89 Hz (CVT 1.31M4) hsync: 63.67 kHz; pclk: 109.00 MHz
Modeline "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync

Probably sent from the sforza (a Blackbird workstation with Fedora) or the moose (a SGI O2).

MPC7500

  • Full Member
  • ***
  • Posts: 189
  • Karma: +11/-0
    • View Profile
    • Twitter
It should work, I guess. Maybe someone else have a clue.

FlyingBlackbird

  • Jr. Member
  • **
  • Posts: 83
  • Karma: +0/-0
    • View Profile
Is there possibly a risk of "overclocking"? Any documentation available that says wrong modelines do not destroy the AST2500?

jirka

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
  • Ordinary Blackbird Owner
    • View Profile
    • Jirka's Notes
Is there possibly a risk of "overclocking"? Any documentation available that says wrong modelines do not destroy the AST2500?

I don't thing so. I didn't find any such statement.

Moreover, it still works in 1920x1080 (after three months in 1920x1200).
Probably sent from the sforza (a Blackbird workstation with Fedora) or the moose (a SGI O2).

jirka

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
  • Ordinary Blackbird Owner
    • View Profile
    • Jirka's Notes
I just tried to boot to the "rescue mode" of my Fedora (it is labelled "F30") and ... the 1920x1200 works.

If I boot with the F32 or the F31 kernel (5.6.8 or 5.6.7) then it does not work (1920x1080 is the maximum).

So can it be a kernel issue?
Probably sent from the sforza (a Blackbird workstation with Fedora) or the moose (a SGI O2).