Author Topic: AMD RX 6900 XT from Sapphire NITRO  (Read 576 times)

tle

  • Full Member
  • ***
  • Posts: 201
  • Karma: +28/-0
    • View Profile
    • Ruby Journal
AMD RX 6900 XT from Sapphire NITRO
« on: March 09, 2021, 12:07:09 am »
Last week I purchased a new AMD RX 6900 XT for gaming. It was running perfectly fine on my Windows gaming rig.

My first few attempts are unsuccessful, I've tried the stock kernel of Fedora 33 (5.10.20) and Fedora 35 (5.12-rc2) but none could recognise the card correctly. Loading amdgpu yields error (see https://pastebin.com/sEucjVqh for 64K page size and https://pastebin.com/VqwiTx3F for 4K page size), I have submitted an issue upstream at https://gitlab.freedesktop.org/drm/amd/-/issues/1519
« Last Edit: March 28, 2021, 07:44:05 am by tle »
Faithful Linux enthusiast

pocock

  • Full Member
  • ***
  • Posts: 223
  • Karma: +22/-0
    • View Profile
Re: AMD RX 6900 XT from Sapphire NITRO [WIP]
« Reply #1 on: March 09, 2021, 07:51:38 am »

As you are using the latest Fedora I suspect you have the latest dependencies, nonetheless, can you confirm you checked the version of:


amd firmware (maybe take directly from Git and copy into your system /lib directory)
https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git

mesa

Xorg or Wayland?  Try both


Maybe we need to develop a small reporting script that people can use to build a comprehensive report of each GPU test, all dependency versions, checksums, logs, key config values, kernel config, etc

Debian Developer
https://danielpocock.com

tle

  • Full Member
  • ***
  • Posts: 201
  • Karma: +28/-0
    • View Profile
    • Ruby Journal
Re: AMD RX 6900 XT from Sapphire NITRO [WIP]
« Reply #2 on: March 09, 2021, 07:57:44 am »
I am using the linux-firmware-20210208-117.fc33 which is reported working with x86_64

I will try to grab the latest firmware from git and see if it helps
Faithful Linux enthusiast

tle

  • Full Member
  • ***
  • Posts: 201
  • Karma: +28/-0
    • View Profile
    • Ruby Journal
Re: AMD RX 6900 XT from Sapphire NITRO [WIP]
« Reply #3 on: March 09, 2021, 08:06:41 am »
No good even with the latest firmware from git source :(
Faithful Linux enthusiast

tle

  • Full Member
  • ***
  • Posts: 201
  • Karma: +28/-0
    • View Profile
    • Ruby Journal
Re: AMD RX 6900 XT from Sapphire NITRO [WIP]
« Reply #4 on: March 14, 2021, 09:59:15 am »
Update: have tried with 5.10.23 but with still no success

Faithful Linux enthusiast

pocock

  • Full Member
  • ***
  • Posts: 223
  • Karma: +22/-0
    • View Profile
Re: AMD RX 6900 XT from Sapphire NITRO [WIP]
« Reply #5 on: March 15, 2021, 04:12:38 am »

Are you using Xorg or Wayland?

It is a good idea to try with both

Have you contacted the amdgpu developers to make a bug report?
Debian Developer
https://danielpocock.com

MPC7500

  • Sr. Member
  • ****
  • Posts: 307
  • Karma: +17/-1
    • View Profile
    • Twitter
Re: AMD RX 6900 XT from Sapphire NITRO [WIP]
« Reply #6 on: March 15, 2021, 10:29:00 am »
Here is his bug report.

tle

  • Full Member
  • ***
  • Posts: 201
  • Karma: +28/-0
    • View Profile
    • Ruby Journal
Re: AMD RX 6900 XT from Sapphire NITRO [WIP]
« Reply #7 on: March 17, 2021, 08:07:47 am »
It crashes instantly when I do `modprobe amdgpu`
Faithful Linux enthusiast

tle

  • Full Member
  • ***
  • Posts: 201
  • Karma: +28/-0
    • View Profile
    • Ruby Journal
Re: AMD RX 6900 XT from Sapphire NITRO [WIP]
« Reply #8 on: March 28, 2021, 07:43:52 am »
I've sold my 6900XT to free up the cash for the upcoming Intel DG2. Fingercross Intel would nail the driver correctly
Faithful Linux enthusiast

MPC7500

  • Sr. Member
  • ****
  • Posts: 307
  • Karma: +17/-1
    • View Profile
    • Twitter
Re: AMD RX 6900 XT from Sapphire NITRO
« Reply #9 on: March 28, 2021, 09:24:54 am »
I've read somewhere that DG2 is Intel only or something like that. But can't find anymore.

tle

  • Full Member
  • ***
  • Posts: 201
  • Karma: +28/-0
    • View Profile
    • Ruby Journal
Re: AMD RX 6900 XT from Sapphire NITRO
« Reply #10 on: March 29, 2021, 04:55:52 am »
The DG1 is only compatible with some Intel motherboards. It does not make sense for Intel to launch DG2 that does not run on non-Intel boards
Faithful Linux enthusiast