Author Topic: talos-openbmc: build failure  (Read 106 times)

resonant

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
talos-openbmc: build failure
« on: December 27, 2020, 03:10:48 pm »
i am using a fedora-32 vm to build the openpower and openbmc firmware, and have setup the debian-chroot config per

https://wiki.raptorcs.com/wiki/Compiling_Firmware

the openpower fw built fine (apart from some messages about signing keys), but i have hit a build error for the raptor-v2.00 branch of talos-openbmc. it fails during obmc-phosphor-initfs.bb:do_install and here is the build log

DEBUG: Executing python function extend_recipe_sysroot
NOTE: Direct dependencies are ['/home/build-user/talos-openbmc/meta/recipes-devtools/gcc/gcc-runtime_8.3.bb:do_populate_sysroot', 'virtual:native:/home/build-user/talos-openbmc/meta/recipes-devtools/pseudo/pseudo_git.bb:do_populate_sysroot', '/home/build-user/talos-openbmc/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_2016.07.bb:do_populate_sysroot', '/home/build-user/talos-openbmc/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed_2016.07.bb:do_populate_sysroot', '/home/build-user/talos-openbmc/meta/recipes-devtools/quilt/quilt-native_0.65.bb:do_populate_sysroot', '/home/build-user/talos-openbmc/meta/recipes-core/glibc/glibc_2.29.bb:do_populate_sysroot', '/home/build-user/talos-openbmc/meta/recipes-devtools/gcc/gcc-cross_8.3.bb:do_populate_sysroot']
NOTE: Installed into sysroot: ['pseudo-native']
NOTE: Skipping as already exists in sysroot: ['gcc-runtime', 'u-boot-fw-utils-aspeed', 'u-boot-aspeed', 'quilt-native', 'glibc', 'gcc-cross-arm', 'mtd-utils', 'os-release', 'linux-libc-headers', 'automake-native', 'libtool-native', 'autoconf-native', 'binutils-cross-arm', 'flex-native', 'gnu-config-native', 'zlib-native', 'texinfo-dummy-native', 'gmp-native', 'xz-native', 'libmpc-native', 'mpfr-native', 'libgcc', 'lzo', 'e2fsprogs', 'util-linux', 'opkg-utils', 'zlib', 'm4-native', 'gettext-minimal-native', 'attr', 'libxcrypt', 'bash-completion', 'libpam', 'ncurses', 'flex', 'cracklib']
DEBUG: Python function extend_recipe_sysroot finished
DEBUG: Executing shell function do_install
install: cannot stat '/home/build-user/talos-openbmc/build/tmp/sysroots/bin/bbe': No such file or directory
WARNING: exit code 1 from a shell command.
ERROR: Function failed: do_install (log file is located at /home/build-user/talos-openbmc/build/tmp/work/armv6-openbmc-linux-gnueabi/obmc-phosphor-initfs/1.0-r1/temp/log.do_install.1459726)

as you can see, the bbe binary is missing.

advice appreciated.

resonant

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: talos-openbmc: build failure
« Reply #1 on: December 28, 2020, 03:15:21 pm »
i decided to take a shot at doing this using a debian 9 vm and the build has failed at the same point.

i had one of the devs i work with take a look at the commit messages for the talos-openbmc repo and he didn't see anything obvious suggesting this issue has been fixed in a commit since the latest raptor-v2.00 commit.

resonant

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: talos-openbmc: build failure
« Reply #2 on: January 15, 2021, 11:18:36 am »
holy brittle build toolchain, batman!

the fix here ended up being to determine which bitbake recipes were responsible for the missing files, then forcing a clean and install on those specific recipes:

bitbake -f -b /home/user/talos-openbmc/meta-rcs/recipes-phosphor/binary-block-editor/binary-block-editor.bb -c clean
bitbake -f -b /home/user/talos-openbmc/meta-rcs/recipes-phosphor/binary-block-editor/binary-block-editor.bb -c install

i also had to do the same for meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed_2016.07.bb. after this, you can restart the build with the usual bitbake obmc-phosphor-image command.

this really should be documented in the wiki so anyone else having the same issues doesn't have to figure out how bitbake works.