Author Topic: Thunderbird not working Debian buster (1:68.12.0-1~deb10u1 & 1:78.4.0-1~deb10u1)  (Read 1529 times)

pocock

  • Sr. Member
  • ****
  • Posts: 276
  • Karma: +30/-0
    • View Profile
When I started using my Talos II system, I moved my $HOME into Debian buster with Thunderbird 1:68.12.0-1~deb10u1

Launching Thunderbird, I found that all the panes (folder list, message list, message preview) were empty and toolbar appears mildly corrupt

I thought I would just wait for Debian to package a newer version.

Thunderbird 1:78.4.0-1~deb10u1 is now available through the Debian buster security updates so I tried that today.

The same problem occurred, all panes empty

I looked for information online and found a few suggestions but these things didn't make any difference:

- running Thunderbird in safe mode

- running Thunderbird in safe mode with all add-ons disabled and selecting the option to reset the toolbar

- running Thunderbird in safe mode to create a new profile

When I try to start in a new profile, I notice that the wizard to create a new mail account never appears.  Trying to access the accounts window from the menu, the window doesn't appear either.

Has anybody else had problems like this on Debian or any other distribution?

Are there any tweaks in the Fedora build of Thunderbird that may be necessary for the Debian build?
Debian Developer
https://danielpocock.com

pocock

  • Sr. Member
  • ****
  • Posts: 276
  • Karma: +30/-0
    • View Profile
Here are some details about my investigation into this issue, I finally got it working by manually patching and rebuilding the package version 68.12 on Debian buster.

It may impact Fedora and other distributions too.

I started with an empty profile and press CTRL-SHIFT-J to bring up the error console.

There were a range of errors, here are some of them:

Code: [Select]
Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)

There are many search results for that.

Code: [Select]
thunderbird Uncaught (in promise) TypeError "this.asyncConnection" is nullcreateNounTable

Searching for that one immediately found a ppc64el-specific bug report in Ubuntu (bug 1845929)

The bug report includes a patch against Thunderbird 68.1.1, they configure Thunderbird to use the system sqlite3 library instead of the bundled version in the Mozilla source tree.

Looking at the debian/changelog (buster) for the Debian buster build, I found that the patch had been reverted at some point after that:

Code: [Select]
thunderbird (1:68.2.2-1~deb10u1) stable-security; urgency=medium

  * Rebuild for buster-security
  * [2c1bd00] d/mozconfig.default: use internal version of
    nspr, nss, sqlite and icu
  * [94d6ae4] d/control: remove lib{nspr4,nss3,sqlite3}-dev from B-D

Further on, around Thunderbird v76 packaging, I found they removed more of the system-sqlite stuff, there is a changelog comment suggesting that the Thunderbird internal sqlite codebase is now a fork.  The patch can no longer be used because the configure option --enable-system-sqlite no longer exists.  Base on my experience with Thunderbird v78, that fork is not working at all on ppc64el.  From the debian/changelog (sid / unstable):

Code: [Select]
thunderbird (1:76.0~b2-1) experimental; urgency=medium

  * [8386db0] d/control: Remove B-D on libjson-dev and libsqlite3-dev
    The built uses internal copies for libjson and libsqlite as there are
    made modifications to them. For now we can decrease the list of build
    dependencies by removing this two packages.

Going forward, I believe somebody will need to create unit tests for exercising the Mozilla fork of sqlite during builds on ppc64el hosts.  Debian and other distributions automatically run the unit tests on every architecture when creating the packages.

I took the Debian buster packaging branch, forked it at v68.12 and re-enabled the system-sqlite option.  This immediately fixed the problem I was experiencing.  For now I have a usable Thunderbird package on buster.

Some additional references I looked at suggested deleting some or all of the following may help people having problems with things not appearing in the folder pane after upgrading or migrating the profile to a different host/CPU architecture.  I personally deleted the cache but didn't need to delete the others:

Code: [Select]
~/.cache/thunderbird
~/.thunderbird/..../folderTree.json
~/.thunderbird/..../session.json
Debian Developer
https://danielpocock.com

MPC7500

  • Sr. Member
  • ****
  • Posts: 485
  • Karma: +32/-1
    • View Profile
    • Twitter
I dunno the version. I will look later, but on Fedora Thunderbird works.

pocock

  • Sr. Member
  • ****
  • Posts: 276
  • Karma: +30/-0
    • View Profile

It depends on the version and it also depends on the flags that were set in the spec file or any patches applied during the build

You can check your thunderbird while it is running like this:

Code: [Select]
$ ps -C thunderbird
  PID TTY          TIME CMD
55840 pts/6    09:35:21 thunderbird

$ lsof -p 55840 | grep libsqli
thunderbi 55840 daniel  mem       REG               0,23               54138 /usr/lib/powerpc64le-linux-gnu/libsqlite3.so.0.8.6 (path dev=0,24)


The above output shows me that the running thunderbird process has used /usr/lib/powerpc64le-linux-gnu/libsqlite3.so.0.8.6 from the standard Debian package.  The path will be slightly different on a Fedora system.
Debian Developer
https://danielpocock.com

MPC7500

  • Sr. Member
  • ****
  • Posts: 485
  • Karma: +32/-1
    • View Profile
    • Twitter
I'm at 78.4.0, too. The command gives me also:
Code: [Select]
/usr/lib64/libsqlite3.so.0.8.6

pocock

  • Sr. Member
  • ****
  • Posts: 276
  • Karma: +30/-0
    • View Profile
That looks like the system-provided version of sqlite

That is what is supposed to work

Debian's packages don't use that by default, that is why they fail to work

Debian Developer
https://danielpocock.com

ClassicHasClass

  • Sr. Member
  • ****
  • Posts: 368
  • Karma: +27/-0
  • Talospace Earth Orbit
    • View Profile
    • Floodgap
That should bite Firefox too, no?

vikings.thum

  • Newbie
  • *
  • Posts: 29
  • Karma: +10/-0
    • View Profile
    • Vikings
That looks like the system-provided version of sqlite

That is what is supposed to work

Debian's packages don't use that by default, that is why they fail to work

2 years later and I tried Thunderbird 102.2.2-1 (from Debian bookworm/testing). Still the same problem(s) as you describe them.
With the (probable) exception, that I get new email notifications. They do not appear anywhere else, though.

Did someone find a fix?
If not, what can we do about it?


That should bite Firefox too, no?

No problems with Firefox (102.2.0esr-1).
https://store.vikings.net
XMPP: thum@jabber.vikings.net
Libera.Chat IRC: #vikings (handle: 'thum')

MauryG5

  • Hero Member
  • *****
  • Posts: 670
  • Karma: +21/-1
    • View Profile
The Thunderbird problem was one of those that I denounced some time ago when I started using Ubuntu and I think the problem is the same as Ubuntu is a derivative of Debian. There is a bug that has never been solved despite the new versions, a bit like it happens on Firefox always on Ubuntu and its perennial problems never solved in an official way. Firefox on Debian works well I confirm everything, Thunderbird on Debian I never installed it because I prefer to use Evolutions which is by default as well and with which I have always found myself well but that problem I remember perfectly on Ubuntu.

vikings.thum

  • Newbie
  • *
  • Posts: 29
  • Karma: +10/-0
    • View Profile
    • Vikings
Yes, I'm aware that there are other email clients available. And yes, they all suck. That doesn't solve the problem we have with Thunderbird if a customer is hell-bent on using it, though :-) I don't think there's a technical reason. Most people just want to use what they're used to and avoid change, I've read that's what the brain prefers.

So I'm still looking for useful suggestions from the hackers we have on board here.

Not having to try Ubuntu will save some time, for some reason I thought the grass is greener over there. Thanks MauryG5.
« Last Edit: September 20, 2022, 04:15:37 am by vikings.thum »
https://store.vikings.net
XMPP: thum@jabber.vikings.net
Libera.Chat IRC: #vikings (handle: 'thum')

MPC7500

  • Sr. Member
  • ****
  • Posts: 485
  • Karma: +32/-1
    • View Profile
    • Twitter
Does this perhaps only affect Debian-based distributions? On VoidLinux Thunderbird works. What about Fedora?
I would ask on the Debian mailing list about Thunderbird.

ClassicHasClass

  • Sr. Member
  • ****
  • Posts: 368
  • Karma: +27/-0
  • Talospace Earth Orbit
    • View Profile
    • Floodgap
Although I use my custom-built Firefox on Fedora, I use Fedora-built Thunderbird, and no problems.

MauryG5

  • Hero Member
  • *****
  • Posts: 670
  • Karma: +21/-1
    • View Profile
I also confirm what MPC and Classic said, when I was using Fedora, I had configured Thunderbird as a mail client and it worked perfectly. The problem is limited to the Debian and derived versions ...