Author Topic: MAME for Power  (Read 242 times)

MauryG5

  • Sr. Member
  • ****
  • Posts: 251
  • Karma: +4/-0
    • View Profile
MAME for Power
« on: December 22, 2019, 07:46:32 am »
Sorry guys but at the level of software dedicated to Power, I was looking for Mame for Power some time ago, I had seen something inherent in our beloved architecture but in the end I did not find anything really downloadable, I read that currently there is not but as usual I will have 'read news that as for VLC is not said correspond to truth so I wonder if you know something more about the MAME situation on Power ... Thanks

q66

  • Newbie
  • *
  • Posts: 46
  • Karma: +13/-0
  • Void Linux for ppc maintainer
    • View Profile
    • Void Linux for PowerPC
Re: MAME for Power
« Reply #1 on: December 22, 2019, 07:11:31 pm »
MAME works on POWER just fine.

ClassicHasClass

  • Jr. Member
  • **
  • Posts: 97
  • Karma: +5/-0
  • Talospace Earth Orbit
    • View Profile
    • Floodgap

MauryG5

  • Sr. Member
  • ****
  • Posts: 251
  • Karma: +4/-0
    • View Profile
Re: MAME for Power
« Reply #3 on: December 23, 2019, 06:30:33 am »
you say it works but I still can't find the version for pc64le, I only see the versions for the other architectures ... where is ours?

MPC7500

  • Full Member
  • ***
  • Posts: 189
  • Karma: +11/-0
    • View Profile
    • Twitter
Re: MAME for Power
« Reply #4 on: December 23, 2019, 08:39:44 am »
Have you read the link above?
If you don't wanna build it by your own, there is only one option: VoidLinux, IIRC
« Last Edit: December 23, 2019, 08:42:23 am by MPC7500 »

q66

  • Newbie
  • *
  • Posts: 46
  • Karma: +13/-0
  • Void Linux for ppc maintainer
    • View Profile
    • Void Linux for PowerPC
Re: MAME for Power
« Reply #5 on: December 23, 2019, 12:29:12 pm »
I patch it with -mlong-double-64 for glibc systems and it seems to be pretty harmless. Glibc supports dual ABI, so for pure libc consumers it's 100% harmless, and there aren't many libraries using long double in their APIs, as far as MAME dependencies go it's none, as far as I can tell.

MauryG5

  • Sr. Member
  • ****
  • Posts: 251
  • Karma: +4/-0
    • View Profile
Re: MAME for Power
« Reply #6 on: December 23, 2019, 02:45:00 pm »
MPC sorry but apart from that as I said several times I am not a Linux expert let alone a programmer, but I don't think I will install a distro just to use Mame ... There is no patience maybe they will do it later and later  in any case I read that Void is not compatible with Power in any case I do not care Void

ClassicHasClass

  • Jr. Member
  • **
  • Posts: 97
  • Karma: +5/-0
  • Talospace Earth Orbit
    • View Profile
    • Floodgap
Re: MAME for Power
« Reply #7 on: December 23, 2019, 09:24:28 pm »
q66 is the Void Power maintainer, so.

MauryG5

  • Sr. Member
  • ****
  • Posts: 251
  • Karma: +4/-0
    • View Profile
Re: MAME for Power
« Reply #8 on: December 24, 2019, 06:52:22 am »
So I turn to Q66 which I have already seen to be one of the most experienced of both Linux and Power architecture, if you have any links where you can go find something, give me a nod ...

q66

  • Newbie
  • *
  • Posts: 46
  • Karma: +13/-0
  • Void Linux for ppc maintainer
    • View Profile
    • Void Linux for PowerPC
Re: MAME for Power
« Reply #9 on: December 24, 2019, 01:34:48 pm »
If your distro doesn't build it, you'll have to build it yourself; if you can't build it yourself, make a request in your distro. I don't know if Fedora builds it, as I don't use Fedora. The patches are out there, in Void it works for ppc64le as well as ppc64 and ppc, I tested it on my Talos and Blackbird.

MauryG5

  • Sr. Member
  • ****
  • Posts: 251
  • Karma: +4/-0
    • View Profile
Re: MAME for Power
« Reply #10 on: December 24, 2019, 02:49:27 pm »
on Fedora if I remember correctly, there is an x86 version of course, it is missing for Power.  No I can't build it myself ...