Author Topic: Running a Windows VM on Fedora 32  (Read 108 times)

cchinicz

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
Running a Windows VM on Fedora 32
« on: May 17, 2020, 12:59:02 am »
Hi All,

I'm new to Talos. I've got a blackbird and installed Fedora 32.

I want to create a Windows 10 VM to run a few applications that are not available on Linux.

Has anyone done this before? Searching on the web I saw people writing about emulating x86 on ppc but not enough details and not specific for Talos.

Thanks

Borley

  • Newbie
  • *
  • Posts: 16
  • Karma: +3/-0
    • View Profile
Re: Running a Windows VM on Fedora 32
« Reply #1 on: May 17, 2020, 10:15:52 am »
You might be interested in the package:
Code: [Select]
qemu-system-x86. I'm not sure how one would set it up but I imagine this can be done under qemu/kvm or entirely virt-manager.

cchinicz

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
Re: Running a Windows VM on Fedora 32
« Reply #2 on: May 18, 2020, 12:25:12 am »
I wonder this is possible but I guess I cannot run Windows code on ppc64el. There must be some x86 emulation but I have no idea how to set it up.

ClassicHasClass

  • Jr. Member
  • **
  • Posts: 97
  • Karma: +5/-0
  • Talospace Earth Orbit
    • View Profile
    • Floodgap
Re: Running a Windows VM on Fedora 32
« Reply #3 on: May 19, 2020, 06:36:35 pm »
This is a QEMU-specific question. Install that, and then follow any of the directions out there for setting up Windows 10 to run within it. Note that many of these assume you will be using KVM; you won't. In this example, remove `--enable-kvm`but the other steps should be fine.

https://www.funtoo.org/Windows_10_Virtualization_with_KVM


cchinicz

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
Re: Running a Windows VM on Fedora 32
« Reply #4 on: May 22, 2020, 09:52:06 am »
Hi ClassicHasClass,

Thanks for sharing the link. I was really excited but the installation of Win 10 failed with both 64/32 bits version. The installation proceeds until the last stage (about some 30 minutes) and fails with a message that there is a missing file/driver.

Any idea of how to fix this? when setting up the install I tried with E:\viostor\w10\amd64 (for the 64 bits version) and with E:\viostor\w10\x86 (32 bits).

Regards

ClassicHasClass

  • Jr. Member
  • **
  • Posts: 97
  • Karma: +5/-0
  • Talospace Earth Orbit
    • View Profile
    • Floodgap
Re: Running a Windows VM on Fedora 32
« Reply #5 on: May 22, 2020, 09:43:50 pm »
That I don't know, I only run Windows 98 on mine. I'll look into it when I get a little time unless someone here is already running W10.