Raptor Computing Systems Community Forums (BETA)

Software => Operating Systems and Porting => Topic started by: MauryG5 on April 19, 2020, 04:53:18 am

Title: Screen Saver disappeared
Post by: MauryG5 on April 19, 2020, 04:53:18 am
Friends of Power good morning, it will seem trivial I know but since I use the dedicated graphics card, it seems that the screen saver has disappeared and I could not find it anymore. I'm sending you the picture of the error that I get every time I open the Screen Saver application, let's see if we need to change something to recover the screen savers that are present by default on Linux...

Title: Re: Screen Saver disappeared
Post by: AlbertoGP on April 22, 2020, 04:38:45 am
The screenshot is not sharp enough to read the error message. After zooming in, squinting, and some help from search engines, this is what I managed to make out:

The XScreenSaver daeomon doesn’t seem to be running on display "??". Launch it now?

In cases like this it’s helpful to type the message as text too. Makes it easier for anyone that wants to help you.

This seems related to the Linux distribution you’re running. My guess is that it was triggered by some other inadvertent change, not switching from the built-in to the dedicated graphics card.

I would try searching for that error message, together with the name and version of the Linux distribution you’re using:

That might uncover some way of setting the XScreenSaver daemon (or that of any other screen saver) to run at startup.
Title: Re: Screen Saver disappeared
Post by: xilinder on April 22, 2020, 08:07:36 am
To have the screensaver autostart on Debian 10 I added it to the 'Startup Applications Preferences'.
Title: Re: Screen Saver disappeared
Post by: MauryG5 on April 22, 2020, 03:44:15 pm
AlbertoGP, thanks for your report, I followed the guide of those sites you posted, in fact the files for the screen savers were missing, I don't know why they disappeared since they were there before the installation of the modified Kernel to enable Navi 10. Maybe by default this Kernel needs to have them installed and so it doesn't have them. I ran the command: yum list | grep -i xscreensaver, he gave me a list and from that list I tried to install all those files it brought back. Some of them were present and some were not and I installed them. The screen savers are finally back, the only problem is that it puts them as files in the settings and I had to group them all in one window. Then he downloaded a lot of them and I had to remove a lot of them because there were really too many. Anyway, I solved it, thank you very much.

Xlinder I looked where you went but I didn't find anything, the problem was they were just missing.