Raptor Computing Systems Community Forums (BETA)

Raptor Computing Systems Hardware => Blackbird => Topic started by: Skirmisher on August 14, 2020, 01:08:40 pm

Title: Stereo audio channels swapped?
Post by: Skirmisher on August 14, 2020, 01:08:40 pm
I noticed a good while back (when first starting to use the Blackbird) that the sound card seemed to have the stereo channels in the wrong order. I tested with multiple audio devices to be completely sure. Has anyone else noticed this, or is it an isolated issue? (The workaround is trivial since I can remap the channels with a PulseAudio config with no negative impact, but I'm still rather curious.)
Title: Re: Stereo audio channels swapped?
Post by: Borley on July 12, 2022, 11:22:38 pm
I've had to swap my headphones L/R around physically a couple of times before I finally figured out that the CM106 sound device had the channels mixed up. You're not the only one.
Title: Re: Stereo audio channels swapped?
Post by: r34per on September 11, 2022, 01:26:50 pm
I fought with getting the 5.1 channels right for days on fedora I just gave up and threw in a sound blaster z. All the cahnnels seem to map right with that card OOTB.
Title: Re: Stereo audio channels swapped?
Post by: MPC7500 on September 11, 2022, 03:48:25 pm
I use the audio of the AMD GPU.
Title: Re: Stereo audio channels swapped?
Post by: ClassicHasClass on September 13, 2022, 11:13:38 am
I don't recall this being a problem on the optical output (which I feed into a Denon receiver), but maybe I'm just not discriminating enough.